Scissor

打开、置入与导出

打开、存储、置入、导出和打印都在你自己的电脑上进行。本页介绍原生的 .cut 文档、Scissor 能读取和写出的格式,以及图稿如何导入和导出。

一切都保留在你的设备上

Scissor 没有服务器,也没有账户。你打开的文件在浏览器中、在你自己的电脑上读取,你导出的文件直接写回你的磁盘。不会上传任何内容,除非你自己把图稿发送到某处,否则它永远不会离开这台电脑。这也意味着没有可以依赖的云端副本,因此请像对待其他桌面文档一样存储你的作品。

在下文的快捷键中,⌘ 在 Windows 和 Linux 上即 Ctrl,⌥ 即 Alt。

.cut 文档

Scissor 自己的格式是 .cut,一种带版本号的 JSON 文件,保存着整个节点树:每个图层、编组、路径、实时形状、文字、置入的图片、渐变、效果和画板,完全保持你离开时的样子。它是唯一能保留 Scissor 所有功能的格式,因此作品仍在制作中时,就应该存储为这种格式。只有当图稿需要转到其他程序或网页时,才需要使用导出格式。

存储你的作品

使用文件 > 存储(⌘S)写入文档,使用存储为…(⇧⌘S)以新名称写入,使用存储副本…(⌥⌘S)在继续编辑原文档的同时另外写入一份快照。

在浏览器支持的情况下,Scissor 会保留你所选文件的句柄,因此之后的存储会直接写回同一位置而不弹出对话框,就像桌面应用程序一样。在不支持的浏览器中,每次存储都会以下载一个新的 .cut 文件的形式完成。如果已存储的文件之后被移动,或其权限被撤回,Scissor 会退回到再次询问你存放位置。

新建和关闭文档

文件 > 新建…(⌥⌘N)通过新建文档对话框打开一个空白文档,你可以在其中设置文档尺寸及初始画板数量。文件 > 打开…(⌘O)读取现有文件,并可一次打开多个。使用文件 > 关闭(⌥⌘W)关闭当前文档。

打开其他格式

文件 > 打开…(⌘O)能读取的不只是 Scissor 自己的文档。你可以一次选择多个文件,或将它们拖到画布上。导入的内容取决于格式。

SVG(.svg)
深度读取。路径和基本形状(矩形、圆形、椭圆、直线、折线、多边形)、编组、嵌套的 svg、use 和 symbol,以及全部变换都能导入。表现属性、内联样式和简单的 <style> 规则(按标签、类或 id)、线性和径向渐变、剪切路径、基本文字(包括沿路径排列的文字)以及嵌入或链接的图像也都能导入。颜色可以是十六进制、rgb、hsl 或 CSS 颜色名称,长度单位可以是 px、点、派卡、英寸、毫米、厘米、em 或 ex。与坐标轴对齐的矩形、圆形和椭圆会作为实时形状导入,因此仍可通过手柄编辑,而不会变成固定的轮廓。带有图层的 SVG 打开后会保留这些图层及其名称,原先隐藏或锁定的图层仍保持隐藏和锁定。图案填色、蒙版、标记和滤镜效果不会被导入。
PDF,以及基于 PDF 的 .ai
每页一个画板。路径、颜色、线条样式、剪切、表单 XObject、带字体和位置的文字,以及图片(包括 JPEG、索引图像和带软蒙版 Alpha 的模板蒙版)都能导入。轴向和径向着色无论是直接绘制还是通过图案填色绘制都能读取。
EPS(.eps、.epsf)
EPS 文件是一个 PostScript 程序,因此 Scissor 会运行它。路径、变换、剪切、灰度、RGB、CMYK、HSB 和专色、线宽、端点、连接和虚线、带孔的复合路径以及带字体的文字都能导入,%%BoundingBox 注释会成为画板(如果文件提供了 %%HiResBoundingBox,则以后者为准)。常用的简写运算符已内置,因此依赖它们的文件无需运行自身的序言即可读取,DOS EPS 所带的二进制封装也会先被解开。EPS 中嵌入的栅格图像会被跳过。
PSD(.psd)
像素图层会在其编组中成为可编辑的像素图层,并保留名称、不透明度、混合模式和隐藏状态。图层蒙版会烘焙到 Alpha 中;矢量蒙版和随文件存储的路径会作为可编辑路径导入;文字图层会作为可编辑文本导入。会产生绘制效果的图层样式(投影、内阴影和发光)会作为实时效果导入。

也可以打开栅格图片(.png、.jpg、.gif、.webp、.bmp、.avif)。从文件对话框打开时,图片会成为独立的文档,位于一个与图像大小相同的画板上;拖放到已打开的图稿上时,则会置入该文档中。

如果某个设计程序使用自己封闭、未公开的格式,其他人都无法读取这些文件,因此 Scissor 不会打开它们。请改为从该程序导出 SVG 或 PDF,Scissor 两者都能读取。

为什么可以读取 .ai 却从不写出

现代的 .ai 文件就是 PDF,因此它可以通过 PDF 导入器打开。写出 .ai 则是另一回事:这个扩展名代表的是另一个程序的文档,一个自称是该类文档、实际却承载 Scissor 自身结构的文件,会误导下一个打开它的人。Scissor 用 .cut 保存自己的作品,在图稿需要流转时则写出 PDF 或 SVG。

置入图稿

文件 > 置入…(⇧⌘P)将 SVG 和栅格图片(PNG、JPEG、GIF、WebP)导入你已打开的文档,而不是新建一个文档。用它将标志、照片或扫描的线稿放入正在制作的版面中。

置入的 SVG 会成为可编辑的图稿:其形状、路径和文字作为可以选择和改变形状的对象进入文档,而不是一张扁平的图片。栅格图像(PNG、JPEG、GIF、WebP)会以原始尺寸作为可编辑的像素图层导入——你可以立即在其上绘画、添加蒙版、调整和应用滤镜,也可以用矢量化进行描摹。像素保存在文档内部,因此永远不会去寻找可能被移动或丢失的链接文件;非常大的照片会被缩小以适合单个表面。

将文件拖到画布上与置入的效果相同,只是 .cut、PDF、.ai、.psd 或 EPS 文件会作为独立文档打开。从剪贴板粘贴图片也会将其置入。要在完成后将实时图稿转换为像素,请使用对象 > 栅格化,它会用所选内容的 2 倍图像替换所选内容。

复制、剪切和粘贴

复制(⌘C)和剪切(⌘X)将所选内容放入剪贴板,粘贴(⌘V)将其放回视图中心附近。Scissor 会保留一份完全保真的副本,用于在应用内部往返,同时也会将所选内容以 SVG 形式写入系统剪贴板,因此你可以将图稿直接粘贴到其他程序中。

有三种变体可控制粘贴的位置:贴在前面(⌘F)和贴在后面(⌘B)将其放在堆叠顺序中当前所选内容的正上方或正下方,原位粘贴(⇧⌘V)将其放在复制时的同一坐标处。由于副本也以 SVG 形式传递,从其他地方复制的文字或图稿也可以粘贴进来,并作为可编辑对象导入。

导出

导出会以适合分享或网页使用的格式写出图稿的副本,而 .cut 文档保持不变。文件 > 导出子菜单包含导出单个文件的命令,另有两种途径可一次处理多个文件。

单个文件

导出为 SVG…将当前画板写出为 SVG。这个写入器非常完整:实时矩形、圆形和椭圆会写成真正的 <rect>、<circle> 和 <ellipse> 元素,因此仍可编辑;线性和径向渐变、图案填色、剪切组和挖空组、不透明度、混合模式和隔离都能保留;投影、模糊、发光和羽化会写成 SVG 滤镜;文字保持为文本,包括路径文字、OpenType 功能设置以及带轮廓的填色。任意形状渐变和渐变网格无法用任何 SVG 渐变描述,因此会写成许多小的彩色单元,确保任何读取器都能正确绘制。置入的图片和像素图层会作为 <image> 元素嵌入。

导出为 PNG…、导出为 PNG @2x…和导出为 PNG(透明)…将当前画板以一倍或两倍尺寸渲染为 PNG,最后一种保留透明背景。导出为 JPEG…和导出为 WebP…写出其他栅格格式;JPEG 不支持透明,因此始终保留画板背景。

导出为 PDF…将整个文档写出为 PDF,每个画板一页。这是一个自主开发的写入器,保留矢量路径、渐变、不透明度、剪切、文字以及带透明度的置入图片,因此结果在其他地方仍可编辑,而不是图稿的一张拼合图片。

导出所选项…只将所选对象写出为 SVG,并裁切到你所选的范围。当你想从繁杂的画板中取出一个图标或一个形状时使用它。

导出为多种屏幕所用格式

文件 > 导出 > 导出为多种屏幕所用格式…(⌥⌘E)一次写出多个文件,这是制作多种尺寸资源的方法。勾选你需要的画板和切片,勾选 PNG、JPEG、WebP 和 SVG 的任意组合,并以列表形式输入缩放比例,例如 1x, 2x, 3x。每个勾选的页面都会以每种勾选的格式、每种缩放比例写出,因此一次运行就能生成一整套文件。矢量输出会忽略缩放比例,因为 SVG 没有固定尺寸。在浏览器允许的情况下,你可以选择一个文件夹,所有文件都会写入其中;否则文件会作为单独的下载项送达。

切片

切片在画布上划定一个矩形区域单独导出,因此你可以从一个画板中切出多个部分。从对象 > 切片中创建:建立将所选内容变为切片,从参考线创建沿参考线切割画板,从所选对象创建为每个所选对象创建一个切片。切片选项…设置切片的名称、格式和缩放比例,释放删除所选切片,全部删除清除所有切片。你也可以用切片工具(⇧K)手动绘制切片。切片会与画板一起出现在导出为多种屏幕所用格式的列表中。

资源面板

资源面板(窗口菜单)导出单个图稿而不是整个画板,适合制作图标集或组件表。选择一些图稿并按添加所选项将其加入列表,然后重命名每个条目:名称会成为文件名。选择一次格式(PNG、JPEG、WebP 或 SVG)和缩放比例,然后按导出,即可按所有组合写出每个资源。每个资源单独渲染,并裁切到其自身的边界。

打印

文件 > 打印…(⌘P)将当前画板发送到浏览器自带的打印对话框。页面会根据画板的比例设为横向或纵向,边距为 12 mm,图稿会适合页面放置。请先在文件 > 文档设置…(⌥⌘P)中设置画板尺寸。