Scissor

界面

Scissor 用一个编辑界面填满浏览器窗口:顶部是菜单栏,其下是控制栏和文档标签页,左侧是工具面板,中间是绘图画布,右侧是面板停放区。一切都在你自己的电脑上运行,因此文档始终留在你放置它的地方,打开时也不会被发送到任何地方。

本页的快捷键以 macOS 形式书写。在 Windows 和 Linux 上,请将 ⌘ 视为 Ctrl,⌥ 视为 Alt;⇧ 即 Shift,⌃ 即 Control。

工作区一览

窗口由几个区域组成,每个区域回答一个不同的问题。记住它们的位置之后,手册的其余部分读起来会更轻松。

菜单栏
位于最顶部的一排菜单,右端有还原和重做以及命令搜索。这里完整列出了编辑器能做的所有事情。
控制栏
菜单下方的长条。它显示当前工具,以及对你此刻所选内容有用的几个控件。
文档标签页
位于控制栏左侧,每个打开的文档一个标签页。面板按钮位于同一行的最右端。
工具面板
沿左边缘排列的窄工具栏,底部是填色和描边控件。
画布和粘贴板
中间供你绘图的大片区域。白色矩形是画板;周围的灰色区域是粘贴板。
面板停放区
右侧的面板栏。需要时它会滑入并覆盖在画布上,关闭时则把空间让回来。
状态栏
窗口底部的一条细线,报告当前工具、所选内容和最近一个可还原的操作。
整个 Scissor 窗口:菜单栏、控制栏、工具面板、画布和面板停放区。
整个窗口。Scissor 跟随系统的浅色或深色设置,这张截图也是如此。

菜单栏

顶部排列着十个菜单。它们汇集了程序中的所有命令,按你正在进行的工作类型分组,而不是按功能恰好位于引擎内部的哪个位置分组。

菜单包含内容
文件新建、打开、关闭、存储、置入、导出、脚本、文档设置和打印。
编辑还原和重做、剪贴板命令、作为子菜单的整个选择菜单、颜色编辑以及首选项。
排列变换、堆叠顺序、对齐、编组以及锁定和隐藏。
路径路径和复合路径命令、变形混合、形状变形和透视、剪切蒙版、文本绕排以及扩展。
创建图案、重复、区域填色、矢量化、渐变网格、画板、切片以及像素图层命令。
效果实时效果:矢量效果组(3D、扭曲和变换、组合形状、风格化、变形等),其下还有一个栅格子菜单。
文字字体、字号和字形、创建轮廓、更改大小写、文本串接以及插入字符。
视图外观(浅色和深色)、轮廓和像素预览、缩放、旋转视图、标尺、参考线、网格和吸附。
工作区面板:最常打开的六个面板、一个文字子菜单、包含其余面板的更多面板子菜单,以及重置面板。
帮助新功能、用户手册、安装、使用条款和关于,顶部有一个搜索字段。

项目旁的勾号表示该设置已开启。以灰色显示的项目当前无法使用,通常是因为没有选择任何内容或没有打开文档。如果命令有快捷键,会显示在菜单的右侧。

你不必记住哪个菜单里有什么。菜单栏右侧标有搜索或输入命令的搜索按钮会打开命令面板;用键盘按 ⌘K 也可打开。输入几个字母,它就会列出所有匹配的命令及其菜单路径和快捷键,以及所有匹配的工具。用 ↑ 和 ↓ 在结果间移动,按 Enter 运行高亮的命令,按 Esc 关闭。当你知道想要什么却不知道它在哪里,或者输入比寻找快捷键更快时,就使用它。帮助菜单也带有自己的搜索字段,可以同样地搜索各个菜单。

还原和重做

菜单栏右侧附近的弯曲箭头用于还原和重做,与 ⌘Z 和 ⇧⌘Z 相同。将指针悬停在按钮上时,它会显示将要撤销的步骤名称,窗口底部的状态栏也会显示同样的信息,因此你总能看到再按一次会还原什么。

工具面板

工具沿左边缘排成一列。它们按类别组织:选择、绘制、文字、线条、形状、上色、改变形状、构建、取样、符号、画板和视图。这一列每次只显示每个类别中的一个工具;将指针停在某个位置上,该类别的其余工具就会向右展开,因此你可以选择同组的其他工具,而这一列不会在你手下移动。每个位置会持续显示该类别中你最后使用的那个工具。

单击某个位置即可选择它所显示的工具。其工具提示会给出工具名称及其单键快捷键,例如选择工具为 V,钢笔工具为 P,文字工具为 T。用键盘切换工具时,对应的位置会短暂亮起,让你看到当前启用的是哪个工具。要一次查看所有工具,命令搜索旁有一个画着三个点的按钮,可打开包含所有工具的浏览器,按类别分组,并随输入进行筛选。

填色和描边

工具下方是填色和描边控件:一个代表填色的实心方块,嵌在一个代表描边的方框中,旁边有一对用于互换两者的小箭头。由于它位于这里而不仅仅在控制栏中,你可以在选择工具之前就选好颜色,下一个绘制的对象就会使用这种颜色。单击填色或方框可打开颜色、色板和渐变选项卡。

按键操作
X在填色和描边之间切换焦点
⇧X互换填色和描边
D恢复默认值:白色填色、黑色描边
/将当前一方设为无

工具栏旁的面板

在填色和描边控件与工具之间,工具面板会根据你正在使用的工具提供一小排面板按钮:绘图工具会让色板和描边面板触手可及,文字工具则提供文字和段落面板,依此类推。这些按钮会在你的手所在之处直接打开单个面板。另有一个按钮可打开完整的停放区。在较矮的窗口中,这一排会折叠为一个列出相同选项的面板按钮,因此工具面板永远不会超出底部边缘。

控制栏

菜单下方的长条会随你的操作而变化。它在左侧显示当前工具的名称,右侧只显示可作用于当前所选内容的控件:填色、描边和描边粗细;所选内容的 X、Y、W 和 H;以及有意义的操作,例如对齐、布尔形状模式、堆叠顺序、编组、取消编组和复制。当内容放不下时,最后一个按钮会将其余内容收进一个菜单,因此控制栏在使用过程中不会重新排布。

在任意数字字段中输入数值并按 Enter,或离开该字段,即可应用该值;↑ 和 ↓ 按步长增减,配合 ⇧ 为十倍步长,配合 ⌥ 为十分之一步长。字段旁的小标签是一个拖动调节器:向左或向右拖动它,即可凭手感更改数值。将指针悬停在工具名称上可显示该工具的前几个选项;单击名称则在控制栏下方打开其完整选项,包含所有开关和数值。

控制栏默认停放在标签页行中,但你可以拖动其手柄使其浮动在画布上方,双击手柄(或使用其停放按钮)即可将其放回。此外,选中对象旁边还可能出现一个紧凑的工具条,只包含其填色、描边和粗细,让颜色设置就在图稿旁边,而不必跨越整个窗口。

快捷工具条

当你选择某个对象时,它旁边会浮现一个小工具条,上面有你最常用的控件,因此你不必移到窗口边缘。对于形状和路径,它包含填色和描边;对于文字,它包含填色、字号、粗体、斜体和对齐方式。拖动时它会让开,松开后再回来。它上面的所有内容在控制栏和面板中也都有。

画布和粘贴板

窗口中间是画布。画板是存放你打算保留的图稿的白色矩形;周围的灰色区域是粘贴板。粘贴板是文档的一部分,因此放在那里的草图、边角料或颜色测试都会随文件一起存储,但导出画板时,只有落在该画板矩形内的内容才会被写出。

平移和缩放

按住 Space 可在按住期间切换到抓手工具,然后拖动即可平移;松开后会回到原来的工具。用鼠标中键拖动也可以平移。滚轮用于滚动,按住 ⌘ 或 ⌥ 滚动滚轮则以指针为中心缩放。

快捷键缩放
⌘= / ⌘-放大和缩小
⌘0使当前画板适合窗口大小
⌥⌘0使所有画板适合窗口大小
⌘1实际大小

画布上方有一个缩放控件,带有减号、加号和适合窗口按钮以及当前百分比;单击百分比可通过菜单使用同样的适合窗口和实际大小命令。

标尺和参考线

⌘R 显示和隐藏标尺,标尺以文档单位从当前画板的左上角开始度量,并带有一个跟随指针的标记。从标尺中向外拖动可将参考线拉到图稿上,将参考线拖回标尺即可删除。你还可以用建立参考线(⌘5)将所选路径转换为参考线,并用释放参考线(⌥⌘5)将其变回路径。用 ⌘; 显示或隐藏所有参考线。智能参考线(⌘U)在你绘制和拖动时显示对齐和度量提示。

网格

网格按画板绘制,可在“视图 › 网格”或网格面板中设置。用 ⌘' 显示或隐藏网格,用 ⇧⌘' 切换吸附到网格。每个画板可以使用六种网格之一:正交、等轴测、六边形、斜角、黄金比例和透视。选择一种网格类型会开启网格,让你立即看到它。网格在其专页中有完整介绍。

历史记录条

当你将指针移近画布的某个角落时,那里会出现一列小刻度:这就是文档的历史记录。将指针悬停在刻度上可显示该步骤的名称,单击某个刻度可直接跳到那里,或者按住并沿刻度向下滑动,让文档向后和向前回放,这样你就能看到某个更改的出现和消失。停放区中的历史记录面板以文本形式列出相同的步骤。

画板和画板条

画板(board)就是 Scissor 对 artboard 的称呼。每个画板的名称显示在其左上角上方,当前画板的边框比其他画板更粗。单击画板名称会切换到画板工具并将该画板设为当前画板,随时可以移动、调整大小或重命名。如果画板设有出血,出血会以红色虚线矩形显示在其周围。通过“创建 › 画板 › 新建画板”添加画板,用画板工具(⇧O)绘制画板和调整其形状,并在画板选项中设置画板的尺寸和名称。重新排列所有画板会将它们整齐地排成一行。

画布上方有一条画板缩览图条,每个画板一个小预览,末尾还有一个添加按钮。单击缩览图可将该画板设为当前画板并使其适合窗口;单击其下方的名称可跳到该画板,并切换到画板工具以便编辑。停放区中的画板面板也会列出它们。

文档标签页

打开的文档以标签页的形式显示在控制栏左侧。标签页显示文档名称,有未存储的更改时名称前会有一个圆点。单击标签页可切换到该文档,单击 × 则关闭它;关闭有未存储内容的文档时会先询问你。用鼠标中键单击标签页可直接关闭,将一个标签页拖到另一个上可重新排列打开的文档。新建(⌥⌘N)、打开(⌘O)和存储(⌘S)位于文件菜单中,关闭是 ⌥⌘W。

标签页默认位于顶部。若要将它们停放在侧边,请开启视图 › 文档标签页置于侧边(首选项中也有此项);侧边栏可以通过拖动其右边缘调宽或调窄,该选择会被记住。

状态栏

窗口底部的这一行从左到右依次报告:就绪指示、当前工具的名称、所选内容的数量(未选择、一个对象或对象计数),以及 ⌘Z 将要还原的操作。它是一个安静的地方,可用来确认你选中了什么,以及下一次还原会撤销什么。

面板停放区

面板位于右侧的栏中。平时画布占据整个窗口;需要面板时,停放区会滑入并覆盖在画布上,关闭后立即把空间让回来。标签页行右侧的面板按钮以及 Escape 键用于打开和关闭停放区;窗口菜单、工作区菜单以及命令面板可打开特定面板。

在 Scissor 中打开的文档,画板上有图稿,停放区中打开了图层和色板面板。
正在编辑的文档,停放区中打开了图层和色板面板。

停放的面板组

面板按组堆叠,每组沿自己的边缘有一列小图标选项卡。将指针停在选项卡上可查看面板名称,打开的面板会在其内容上方显示自己的名称。默认情况下,各组汇集了经常一起使用的面板:

重新排列面板

布局可以由你随意更改。沿选项卡所在的条拖动可重新排序,拖到另一组的条上可将其移到那里,拖离停放区则会让它浮动在画布上方。拖动条的空白部分可将整组拖出,再放回停放区上方即可归位;组与组之间的空隙可以接收拖放的选项卡,使其成为一个新组。右键单击选项卡可通过菜单进行同样的移动,包括关闭面板。条顶部的 × 用于关闭该组,拖动两组之间的分隔线可增加一组的高度并减少另一组的高度。浮动的组可以从其角落调整大小。

等待操作对象的面板

当前没有可作用对象的面板不会消失:它的选项卡会保留,只是变暗,其主体会显示一行文字,说明它在等待什么,例如选择一个对象或选择文字工具。为了不让停放区在你手下重新排列,指针位于停放区内时这种等待状态会保持不变,指针离开后才会更新。

打开、隐藏和重置面板

从工作区菜单打开面板,其中最常用的六个位于顶部,其余的位于更多面板下;在经典界面中则从窗口菜单打开。许多面板都有快捷键:

面板快捷键面板快捷键
图层F7颜色F6
绘制堆栈⇧F6信息F8
对齐⇧F7变换⇧F8
描边⌘F10渐变⌘F9
组合形状⇧⌘F9透明度⇧⌘F10
图形样式⇧F5画笔F5
特性⌘F11符号⇧⌘F11
字符⌘T段落⌥⌘T
字形⌥⇧F11

拖动停放区的左边缘可将其加宽,从舒适的每行两个字段的宽度到宽得多的尺寸都可以。你的布局以及停放区的宽度会在会话之间被记住。停放区关闭时,将指针扫到窗口右边缘会让它探出来,前提是指针下方没有图稿。要撤销你对布局所做的全部更改,请选择重置面板,它会将每个组放回其初始位置。

Tab 会隐藏工具面板、控制栏、文档标签页、状态栏、面板以及画布上的其他界面元素,只留下图稿和菜单栏;再按一次即可全部恢复。

语言

Scissor 支持英语、德语(Deutsch)、西班牙语(Español)、法语(Français)、意大利语(Italiano)、加泰罗尼亚语(Català)、捷克语(Čeština)、丹麦语(Dansk)、挪威语(Norsk)、波兰语(Polski)、斯洛伐克语(Slovenčina)、芬兰语(Suomi)和瑞典语(Svenska)。首次打开时,如果你的浏览器语言是其中之一,它就会使用该语言,否则使用英语。要选择其他语言,请单击菜单栏或欢迎屏幕上的地球图标按钮,或打开编辑 › 首选项(⌘K),进入界面,在语言下选择一种。Scissor 会在重新加载时切换语言,并记住你的选择。菜单、面板、对话框、工具提示、消息和新功能都会随之切换,数字也会按当地方式显示,例如德语中的 12,5,不过你可以输入逗号或小数点。你的文档不受影响:图层名称和图稿中的文字保持你写入时的样子。当界面不是英语时,使用条款会显示译文以便阅读,但适用的是英文版本。

浅色和深色

Scissor 跟随系统的浅色和深色设置。若要固定使用其中一种,请选择“视图 › 外观”,然后选择系统、浅色或深色。该选择会被记住,并且不仅作用于界面,也作用于画布:粘贴板、标尺和画板标签都会按你所处的主题绘制。