文字
Scissor 中的文字始终保持实时。你可以随时重新编辑文字内容、字体和间距,并且文本会在你输入时直接绘制到画布上,因此你编辑的内容就是打印和导出的内容。
下面的快捷键以 macOS 形式书写。在 Windows 上,请将 ⌘ 视为 Ctrl,⌥ 视为 Alt,⇧ 视为 Shift。
文字工具
文字工具共用工具栏中的一个位置。选择该位置并按住即可在其中选择,然后在画布上操作。
| 工具 | 快捷键 | 作用 |
|---|---|---|
| 文字工具 | T | 单击创建点状文字,拖动创建矩形区域文字框 |
| 区域文字工具 | 拖出一个文本框并在其中输入 | |
| 路径文字工具 | 单击路径,使文字沿路径排列 | |
| 直排文字工具 | 将直立的字符排成纵列 | |
| 字形编辑工具 | ⇧T | 一次移动、调整大小和旋转一个字符 |
要编辑页面上已有的文字,可使用除字形编辑工具外的任一文字工具单击它,将光标置于其中,或使用选择工具(V)双击它。按 Escape 或在别处单击即可停止编辑。使用普通的文字工具时,单击一条开放路径会将文字附着到该路径上,而不是新建一个文字块,因此你不一定非要使用专门的路径文字工具。
点状文字、区域文字和路径文字
文本可以通过三种方式放在文档中,区别在于行的测量方式以及在何处换行。这三种文字都保持可编辑,接受相同的字符和段落设置,并且以后都可以转换为轮廓。
点状文字
使用文字工具单击一次,然后输入。文本从这一个点开始延伸,只在你按 Return 的地方换行:没有可供换行的文本框。点状文字适用于标题、标签、几个字的展示文字,或任何你会凭眼睛定位而不是倒入一栏的内容。它的缩进和段落间距没有可测量的参照,因此这些控件对点状文字不起作用;对齐方式取自你单击的锚点。
区域文字
使用文字工具或区域文字工具拖出一个矩形,文本就会换行以适合文本框,在右边缘自动换行。区域文字适用于正文、图注,或任何必须保持在固定宽度内的文本。当文本超出文本框的容量时,多余部分会被隐藏,文本框会被标记为溢出;可以放大文本框、缩小文字,或将溢出文本串接到另一个文本框中(见下文)。缩进、首行缩进、段前和段后间距以及连字都适用于区域文字。
路径文字
使用路径文字工具单击一条路径。该路径会成为基线,不再作为独立的图稿存在,因此不再有填色或描边。可以用它让标签环绕徽章、沿曲线排列或越过形状顶部。选中结果后会出现三个括号:一个在起点、一个在终点、一个在中间。拖动起点或终点括号可移动文字沿路径开始和结束的位置,拖动中间括号可使整段文字沿路径滑动,将中间括号拖到路径的另一侧则可翻转文字。路径文字不接受换行,因此编辑时按 Return 不起作用。改变下方路径的形状,文字会跟随其新的弯曲。
字符面板
字符面板(⌘T,或窗口 > 文字 > 字符)包含所有作用于字母本身的设置。选中文字对象时,其设置作用于整个对象:更改字体或字距调整,每个字符都会随之变化。输入时,字体、粗细、斜体和大小仅应用于所选字符(参见同一文本中的混合样式)。在你编辑文字或选中文字对象之前,该面板显示为灰色。
字体、粗细、样式和大小
字体菜单可以搜索,并将你最近使用过的字体系列保留在顶部。它列出浏览器实际能够绘制的字体,在系统允许报告时从系统中读取,否则从一组常见字体系列中探测,因此该列表与实际能渲染的字体相符,而不是一份固定的目录。
粗细菜单提供细体、常规、中等、半粗体、粗体和特粗,但只有所选字体系列确实拥有的粗细才可选择:其他选项会变暗。旁边的斜体按钮可开启或关闭倾斜样式。大小以像素为单位,在大小字段中设置。
同一文本中的混合样式
同一段文本可以混合不同的大小、颜色、粗细和斜体。输入时,选择一些字符,然后通过文本旁的快捷栏、选项栏或颜色面板更改它们。只有所选字符会改变,文本的其余部分保持各自的样式。如果未选择任何字符,更改照常应用于整段文本。继续输入时,样式会随其字符一起移动,并且在 SVG 和 PDF 导出中都会保留。
行距、字距调整和字偶间距调整
- 行距
- 从一条基线到下一条基线的距离,以像素为单位。保持为 0 即为自动行距,即大小的 120%。设置得更大可拉开行距,设置得更小可使标题更紧凑。
- 字距调整
- 为每个字符均匀增加或减少的间距,以千分之一全角为单位(因此会随大小缩放)。正值使文本更松散,负值使文本更紧凑。可以用字距调整让一行文字适合某个宽度,或拉开小型大写字母的间距。
- 字偶间距调整
- 字体自身为特定字母对设定的间距,例如大写 T 下方的空隙。它默认开启,位于 OpenType 行中的字偶间距调整按钮上(标记为 AV)。关闭它可查看字体的原始度量。
对齐
字符面板有四个对齐按钮:左对齐、居中、右对齐和两端对齐。左和右是相对于阅读方向而言的,因此它们表示起点和终点:设为左对齐的从右到左文本会对齐到视觉上的右侧。两端对齐会拉伸每一行以填满行宽,因此只在有换行的地方才会产生变化,也就是区域文字和路径文字,而不是单行的点状文字。如需更精细的两端对齐控制(最后一行如何排列),请使用段落面板。
OpenType 功能和小型大写字母
在 OpenType 标题下有一行按钮,每个按钮可开启或关闭所选文字的一项功能:
| 按钮 | 功能 |
|---|---|
| fi | 标准连字(默认开启) |
| st | 自由连字 |
| TT | 全部大写字母 |
| Tᴰ | 小型大写字母 |
| T¹ | 上标 |
| T₁ | 下标 |
| ½ | 分数字 |
| 1ˢᵗ | 序数字 |
| 𝒜 | 花饰字 |
| AV | 字偶间距调整(默认开启) |
全部大写字母会将每个字母绘制为大写,但不改变底层文本,因此编辑时它仍是小写。小型大写字母会向字体请求其小型大写字形。上标和下标会将相关字符绘制得更小并使其偏离基线,用于脚注标记、序数词尾或化学式。
在按钮下方,数字样式菜单用于选择数字的排列方式:默认数字、等宽全高数字、比例旧式数字、比例全高数字或等宽旧式数字。等宽数字的宽度都相同,因此成列的数字能够对齐;旧式数字带有上伸部和下伸部,更适合融入正文。
并非所有功能都能在画布上预览。连字的开关、字偶间距调整、全部大写、小型大写字母以及上标和下标会在编辑时绘制出来。自由连字、数字样式、分数字、序数字和花饰字会记录在文字上,并作为字体功能设置写入导出的 .svg 中,但画布不会显示它们,因此请将它们视为导出时的设置。
段落面板
段落面板(⌥⌘T,或窗口 > 文字 > 段落)控制整个段落的排列方式。与字符设置一样,这些设置应用于文字对象的每个段落。
顶部横排着七个对齐按钮。前三个是普通的左对齐、居中对齐和右对齐。接下来的三个使段落正文两端对齐,只单独设置最后一行,使其左对齐、居中对齐或右对齐。最后一个使包括最后一行在内的每一行都两端对齐,将最后一行拉伸至整个行宽。两端对齐需要有换行的地方,因此只在区域文字中生效,在点状文字中不生效。
对齐按钮下方是缩进:左和右使整个段落从文本框两侧向内缩进,首行只缩进第一行。负的首行缩进会使第一行悬挂在其他行之外,这就是制作悬挂缩进的方法。段前和段后字段在每个段落的上方和下方添加间距,这是比空行更整洁的分隔段落的方法。连字开关允许长单词跨行断开,使右边缘更整齐。缩进和间距适用于区域文字;点状文字则以其自身的锚点为准。
字形面板
字形面板(文字 > 字形,⌥⇧F11)按字符集列出当前字体的字符,从基本拉丁字母到希腊字母、西里尔字母、希伯来字母、阿拉伯字母、标点、货币符号、箭头等,并将你最近使用过的字符保留在顶部。可以用它插入键盘无法输入的字符,例如箭头、货币符号或带重音的字母。双击一个字形即可在文本光标处输入它。如果光标不在任何文字中,字形会被复制到剪贴板,以便你粘贴到其他地方。
直排文字和从右到左文字
Scissor 既可以横向排列文本,也可以纵向排列文本,还可以排列从右向左阅读的文字。两者都适用于点状文字、区域文字和路径文字,并且画布上的编辑器与最终图稿的方向一致。
直排文字
直排文字工具排列向下堆叠的直立字符,每一新行都会在上一行的左侧形成一列。在直排区域文本框中,一列到达底部时会换到新的一列。要将已排好的文本在横排和直排之间切换,请选择文字 > 文字方向 > 水平或垂直。
从右到左和阿拉伯文
字符面板的方向菜单提供自动、从左到右和从右到左三个选项。选择自动时,方向从文本本身读取,依据其第一个强方向字符,因此阿拉伯文或希伯来文无需任何设置即可从右向左排列。阿拉伯字母会采用其连写形式,从右到左行中的一串拉丁文单词会保持其自身的从左到右顺序。当你想强制指定方向而不是让其自动检测时,例如对于以数字或标点开头的行,请将菜单设为从左到右或从右到左。
字形编辑
字形编辑工具(⇧T)一次移动、缩放和旋转一个字符,同时保持文本完全可编辑。可以用它微调单个字母以获得效果,而无需将单词拆分为轮廓。选择该工具并单击一个字符:该字符周围会出现一个框,每个角各有一个控制点,右侧一个,底部一个,上方还浮着一个。拖动角控制点可在两个方向上缩放,拖动侧边控制点只调整宽度,拖动底部控制点只调整高度,拖动顶部控制点可旋转字符。拖动角控制点时按住 ⇧ 可保持比例,旋转时按住则可对齐角度。Backspace 或 Delete 会将字符放回文本排列的原位,Escape 则取消选取。由于文本始终是文本,你可以继续编辑所移动字符周围的文字。
串接和文本绕排
有两项功能可让文字与版面的其他部分共享空间:串接让一篇文章贯穿多个文本框,文本绕排则使文字避开与之重叠的对象。
串接文本
选择两个或更多区域文字对象,然后选择文字 > 串接文本 > 创建。它们的文本会合并为一篇文章,按堆叠顺序从后到前在文本框之间流动,并且始终从第一个文本框进行编辑。可以使用串接让文章跨越多栏或多页:当你添加或删除文本时,它会在整个链中重新排列。每个文本框的左上角和右下角都有一个端口,并有一条线连到文本继续所在的文本框。如果出口端口位置显示红色加号,则表示文本超出了文本框的容量。释放所选文字会将所选文本框从串接中移出,移除串接会断开整个串接,每个文本框保留其正在显示的文本。
文本绕排
要使文字避开某个形状,请选择该形状,然后选择对象 > 文本绕排 > 建立。位于该对象下方的区域文字随后会围绕它排列。绕排沿对象的轮廓而不是其定界框进行,因此文本可以紧贴圆形或不规则的剪影。文本绕排选项…可设置对象与文本之间保留的间隙(以像素为单位),并可反向绕排,使文字在形状内部而不是围绕形状排列。释放会移除绕排。
将文字转换为轮廓
选择一些文字,然后选择文字 > 创建轮廓(⇧⌘O)即可将其转换为路径。当你需要手动改变字母形状、确保文字在缺少该字体的计算机上看起来完全相同,或将字母用作与其他图稿组合的形状时,就可以使用此功能。字母形状以高分辨率从字体自身的字形描摹而来,拟合时保持真正的尖角锐利,同时平滑曲线,结果会保留文字的填色、描边、名称、不透明度和混合模式。之后这些文字将无法再作为文本编辑,因此如果以后可能需要更改,请保留一个副本,或使用 ⌘Z 还原。