ピクセルレイヤーへのペイント
Scissor のドキュメントには、描画したパスやテキストと並んで、ペイントしたピクセルを含めることができます。そのため、1 つのファイルにやわらかなブラシのテクスチャー、写真、くっきりしたロゴを一緒に収められます。このページでは、ピクセルレイヤーとは何か、その上にどうペイントするか、そしてドキュメント内のオブジェクトとしてどのように振る舞うかを説明します。
ピクセルとベクターアートワーク
Scissor のドキュメントには、2 種類のアートワークが並んで存在します。パスとテキストは描画されたものです。形として記述されているため、どのサイズでもくっきりしたままで、Scissor はズームや拡大・縮小のたびに描き直します。ピクセルレイヤーはペイントされたものです。写真やブラシで描いた絵のような色の点のグリッドで、拡大するとディテールが増えるのではなく、点が大きくなります。1 つのドキュメントにどちらもいくつでも、どんな順序でも含めることができ、レイヤーパネルで一緒に重なります。
シェイプだけでは足りないときにピクセルレイヤーを使います。手描きの影、すっきりしたテキストの背後のラフなテクスチャー、編集可能なパスである必要のない色のしぶき、配置した写真の上でのレタッチなどです。ロゴ、図表、後でサイズを変えるものはベクターのままにしておき、絵の具の質感がほしい部分にピクセルを使います。
配置した写真は関連はしますが別のものです。ファイル > 配置…(⇧⌘P)は既存の画像を埋め込み画像としてドキュメントに取り込みます。ピクセルレイヤーは、Scissor の中でゼロからペイントする面です。どちらもピクセルでできていてスポイトでサンプリングできますが、ブラシのストロークを受け付けるのはピクセルレイヤーだけです。
ピクセルレイヤーの作成
オブジェクト > ピクセルレイヤー > 新規ピクセルレイヤーは、作業中のボードを覆う空の面を追加します。ただし、先に作成する必要はありません。ブラシを選んでペイントすれば、最初のストロークが置かれた瞬間に Scissor がレイヤーを作成します。どちらの場合もレイヤーはボードに対応付けられるため、ピクセルは作成時の解像度にかかわらずアートボードに揃います。
その解像度はラスタライズ効果の設定で決まり、この設定はファイル > ドキュメント設定…(⌥⌘P)にあります。スクリーン(72 ppi)、中解像度(150 ppi)、高解像度(300 ppi)があります。設定を高くすると新しいピクセルレイヤーの 1 ポイントあたりの点が増えるため、作品をプリントしたり大きく表示したりしてもブラシの跡がなめらかなままです。ピクセル数は面の作成時に固定されるため、レイヤーを作る前に設定してください。
モダンシェルでは、ツールオプションバーからもレイヤーを追加できます。ブラシまたはピクセル消しゴムがアクティブなとき、バーの末尾に新規ピクセルレイヤーボタンがあります。
画像を配置してもピクセルレイヤーができます。画像をカンバスにドロップする、ファイル > 配置…を使う、またはクリップボードからペーストすると、ロックされた画像ではなく、元のサイズの編集可能なピクセルレイヤーとして取り込まれます。そのため、すぐにペイントしたり、マスクしたり、色調補正やフィルターをかけたりできます。ファイル > 開くで画像を開くと、画像と同じサイズのボードが 1 つある新規ドキュメントが作られ、ピクセルレイヤーで埋められます。非常に大きな写真は、ピクセルの上限に収まるように縮小されます。SVG はベクターのまま(パスは編集可能なまま)なので、ピクセルレイヤーになるのはビットマップ画像(PNG、JPEG、GIF、WebP など)だけです。
レイヤーのある .psd ファイルは、より豊かに取り込まれます。開くと、その重なりが別々のピクセルレイヤーとして再構築され、各レイヤーのマスクが保たれ、テキスト、シェイプ、レイヤー効果も引き継がれるため、1 枚の平らな画像ではなく、作成された環境での見た目に近い状態で開きます。これはピクセル作業へ入る最も充実した方法で、このページの内容はすべて、取り込まれたレイヤーに当てはまります。
ペイント
ブラシとピクセル消しゴム
ピクセルレイヤーに作用するツールは 2 つあります。
| ツール | 場所 | 機能 |
|---|---|---|
| ブラシツール | ブラシ(B)および塗りブラシ(⇧B)と位置を共有 | 画像の一部になるカラーを置きます |
| ピクセル消しゴムツール | 消しゴム(⇧E)、はさみ、ナイフと位置を共有 | ペイントを消して、下にあるものが透けて見えるようにします |
どちらかを使うには、ツールバーに表示されているツールを長押しするか右クリックし、一覧からピクセルツールを選びます。隣のベクターツールと混同しないでください。ベクター側のブラシは後で形を変えられるパスを描き、ピクセルのブラシはポイントを編集し直せないピクセルをペイントします。どちらのピクセルツールも、ペイントするサイズの円をカンバス上に表示し、十字のポインターを使います。
ドラッグしてペイントまたは消去します。Scissor はストロークに沿って丸い点を連ねて置き、ポインターが飛んでも等間隔に保つため、どれだけ速く動かしても、跡はすき間なくポインターに追従します。ピクセル消しゴムは上から塗るのではなくアルファを取り除くため、消した部分は完全に透明になります。何もなくなるまで消されたタイルは破棄されるため、消去で容量が残ることはありません。
塗りのカラーでのペイント
ブラシは現在の塗りのカラーでペイントします。ほかの塗りと同じように設定します。カラーパネル、スウォッチ、またはモダンシェルでブラシがアクティブなときはツールオプションバーのカラーチップです。塗りが空の場合、ブラシは線のカラーを使い、カラーがまったくない場合は黒を使います。すでに置いたペイントに合わせたいときは、スポイトでピクセルレイヤーから直接カラーを拾います。
サイズ、硬さ、流量
ブラシまたはピクセル消しゴムがアクティブなとき、ツールオプションバーには跡の形を決める設定があります。これらは環境設定にも保存されるため、セッションをまたいで引き継がれます。
- サイズ
- ブラシの直径で、1~2500 ピクセルです。[ を押すとブラシが小さく、] を押すと大きくなります。1 回押すごとにサイズが 5 分の 1 ずつ変わるため、変化量はブラシの大きさに比例します。カンバス上の円が現在のサイズを示します。
- 硬さ
- 縁がぼけ始める位置をパーセントで指定します。100% では縁がくっきりし、下げると点の縁に向かってなめらかに減衰し、目に見える輪はできません。影や光彩にはやわらかいブラシ、塗りつぶした形には硬いブラシを使います。
- 流量
- 1 つの点が置くペイントの量で、ブラシ専用です。100% 未満では、同じ場所を重ねて通るたびにカラーが徐々に重なっていくため、陰影付けやゆるやかなブレンドに適しています。ピクセル消しゴムには流量の設定はありません。
覆い焼き、焼き込み、スポンジ
3 つのレタッチブラシは、カラーを置くのではなく、すでにあるピクセルに手を加えます。これらはツールバーの 1 つの位置を共有しています。ブラシと同じように、同じサイズ、硬さ、カンバス上の円でペイントし、同じ場所を重ねて通るたびに効果が重なるため、軽く使えば少しずつ、強く使えばすばやく変化します。
- 覆い焼き
- ペイントした場所を明るくし、影を持ち上げてハイライトを加えます。
- 焼き込み
- ペイントした場所を暗くし、影や縁を深めます。
- スポンジ
- 彩度を上げ、重ねるほどカラーが豊かになります。
どれも透明なピクセルには手を加えず、選択範囲が設定されているときはその内側にとどまり、ストローク全体を 1 ステップで取り消せます。
塗りつぶし、シェイプ、グラデーション
ペイントはブラシだけではありません。ピクセルレイヤー上では、さらに 3 つのツールでカラーを置けます。塗りつぶしツールは、クリックした場所から似た色の連続した領域を塗りつぶします。シェイプツールは、パスを描く代わりに長方形、楕円、スター、多角形をピクセルに直接押し付けます。グラデーションツールは、面に線形または円形のブレンドをペイントします。どれも現在の選択範囲に従うため、塗りつぶしやグラデーションを選んだ領域に限定できます。
ピクセルの選択
ピクセル選択範囲(選択範囲の囲み)は、ステンシルのように、すべてのペイントと編集をその内側の領域に限定します。ピクセル選択の位置を共有する 3 つのツールで作成できます。長方形選択と楕円形選択、そして手でなぞるフリーハンドのなげなわ選択です。ドラッグして選択範囲を描きます。修飾キーなしでドラッグすると、現在の選択範囲が置き換わります。
自動選択は、形ではなくカラーで選択します。ピクセルレイヤーをクリックすると、クリックした場所の周りにつながっている同じカラーの領域を選び、その周りに点線の輪郭を描きます。平らな背景や 1 つの色の領域を取り出すのに便利です。どれだけ近いカラーを含めるかは、自動選択のオプションの許容値で決まります。これはベクターオブジェクトで使うのと同じ設定です。上げるとより多くを集め、下げると近い一致だけに絞ります。領域内の穴は選択範囲から除外されます。
選択範囲は組み合わせられるため、複数のストロークやクリックから形を作れます。⇧ を押すと選択範囲に追加、⌥ を押すと削除、両方を押すと共通範囲だけを残します。選択範囲の囲みツールも自動選択も、同じ方法で組み合わせられます。選択 > すべてを選択(⌘A)はすべてのピクセルを選択し、選択 > 選択範囲を反転は囲みを反転し、選択を解除(ピクセルレイヤー上では ⌘D)は選択範囲を取り除きます。選択範囲はカンバス上に点線の輪郭で表示されます。
ピクセルの移動、カット、コピー
選択範囲が設定されているとき、選択ツールはその内側のピクセルを移動します。囲みの内側からドラッグすると、選択したペイントが持ち上がって移動し、元の場所は消去され、囲みも一緒に移動します。ドラッグ中に ⌥ を押すと、元をその場に残してコピーを移動します。
変形ツールも選択範囲に作用します。囲みが設定されているとき、選択ツールのバウンディングボックスと自由変形ツール(E)は、レイヤー全体ではなく囲みを包むため、画像のその部分だけを拡大・縮小、回転、移動できます。オブジェクト > 変形と矢印キーも同じように作用します。持ち上げたピクセルは作業中レイヤーの上に浮いているため、ディテールを失わずに何度でもドラッグし直せます。Enter を押すか、別のツールを選ぶか、新しい選択範囲を作ると、ピクセルが下ろされます。これは 1 ステップで取り消せます。Escape を押すと、すべてが元の位置に戻ります。ピクセル単位での移動はピクセルを元のまま保ちます。拡大・縮小や回転では、下ろすときに一度だけ再サンプリングされます。
自由変形ツールのパスの自由変形と遠近変形もピクセルに使えます。囲みにもレイヤー全体にも使えます。ボックスの角をドラッグする(または自由変形モードで ⌘ を押しながら角をドラッグする)と、画像をゆがめることができます。たとえば、斜めから見たスクリーンや看板に写真を合わせるときに使います。ドラッグ中は画面サイズに合わせた簡易プレビューが表示されるため、大きな写真でもなめらかに動きます。ピクセル自体は、Enter を押すか次の作業に移ったときに、フル解像度で一度だけ引き伸ばされ、囲みは新しい形に追従します。
コピー(⌘C)とカット(⌘X)は、囲みの内側のピクセルに作用します。コピーはレイヤーをそのまま残し、カットはピクセルを取り出します。ペースト(⌘V)は、それらを元のレイヤーのすぐ上の新規ピクセルレイヤーのまったく同じ位置に置くため、単独で移動や変形ができます。同じコマンドは作成 > ピクセルレイヤーにもあり、選択範囲は面に対するコマンドにも作用します。塗りのカラーで塗りつぶすは選択した領域だけを塗りつぶし、消去と削除はそこを消します。選択範囲がない場合は、それぞれレイヤー全体に作用します。
色調補正
オブジェクト > ピクセルレイヤー > 色調補正サブメニューは、ピクセルレイヤーのカラーをレタッチします。選択範囲が設定されているときはその範囲に限定されます。それぞれダイアログが開き、ドラッグしながらカンバス上でプレビューできます。
- 明るさ・コントラスト、レベル補正
- 全体の明るさとコントラストを設定するか、黒点、白点、ガンマを再マッピングしてより細かく階調を制御します。
- 色相・彩度、自然な彩度
- 色相をずらし、全体の彩度を上げ下げします。自然な彩度を使うと、すでに鮮やかなカラーはそのままに、くすんだカラーを強めます。
- カラーバランス
- 中間調を、シアンかレッド、マゼンタかグリーン、イエローかブルーの方向へ寄せます。
- グラデーションマップ
- 明るさに応じてレイヤーの色を変え、シャドウを 1 つのカラーに、ハイライトを別のカラーに対応付けます。
- 彩度を下げる、階調の反転
- すべてのカラーをグレーにするか、すべてのカラーを反対色にします。
- 2 階調化、ポスタリゼーション
- 画像を指定したレベルで純粋な白と黒に、またはチャンネルごとに少数の階調に減らします。
フィルター
フィルターサブメニューは、こちらも選択範囲内で、ピクセル自体の形を変えます。
- ぼかし(ガウス)
- レイヤーを均一に、調整可能な量だけぼかします。
- シャープ、アンシャープマスク
- ディテールをくっきりさせます。アンシャープマスクでは、半径、量、そして平坦な領域と細かいノイズを除外するしきい値を制御できます。
- モザイク
- 画像を正方形のタイルに区切ってモザイクにします。
- ノイズを加える
- ペイントに粒子を散らします。
- 輪郭検出、エンボス
- カラーが変わる場所を、暗い背景上の明るい線として、またはグレーのレリーフとしてなぞります。
フィルター > 効果のプレビューは、レイヤーをライブサムネールのグリッドとして表示し、それぞれに 1 つの色調補正またはフィルターを適用します。そのため、名前ではなく見た目で選べます。サムネールを選んでもウィンドウは開いたままです。効果の設定がグリッドの横に表示され、変更するとカンバスで結果をプレビューできます。適用をクリックする(または Enter を押す)まで何も適用されません。キャンセルまたは Esc で画像は元に戻り、適用した効果は 1 回の取り消しで取り除けます。ウィンドウはタイトル部分をドラッグして動かせるため、背後のカンバスを確認できます。
タイル方式の高速な取り消し
ストローク全体は、どれだけ長くても 1 ステップで取り消せます。⌘Z を 1 回押すと最後の跡が消え、⇧⌘Z で元に戻ります。最初のストロークでレイヤーを作成した場合、そのレイヤーは空のまま残されるのではなく、ストロークと一緒に取り消されます。
内部では、ピクセルレイヤーは小さなタイルのグリッドとして保持され、ストロークは実際に触れたタイルだけをコピーします。取り消しではドキュメント全体のスナップショットを保持しますが、ストロークにかかるのは面全体ではなく自分のタイル分だけなので、大きなレイヤーへのペイントも速いままで、長時間ブラシ作業をしてもメモリーがいっぱいになりません。1 色の平坦な領域はコンパクトに保存されるため、ほとんどが 1 色のレイヤーはほとんど容量を取りません。
ピクセルレイヤーをほかのオブジェクトと同じように扱う
ピクセルレイヤーはドキュメント内のオブジェクトなので、すでに知っていることはすべて当てはまります。選択して移動し、オブジェクト > 変形、バウンディングボックス、自由変形ツールで、拡大・縮小、回転、リフレクト、シアーができます。囲みがない場合、ボックスは面全体ではなくレイヤーのペイントされたピクセルを包み、変形はそれらのピクセルに作用します。移動ではピクセルはそのまま保たれ、拡大・縮小や回転は Enter を押すか、別のツールを選ぶか、ほかのものを選択したときにピクセルに焼き付けられます。そのため、レイヤーはまっすぐなままで、次のブラシストロークは正しい向きで置かれます。透明パネルで不透明度を設定し、16 種類の描画モードのいずれかを指定すると、ペイントしたカラーを下にある描画されたアートワークに重ねられます。クリックでレイヤーが選ばれるのはペイントがある場所だけなので、透明な角をクリックすると、その下にあるものを直接選べます。複製はピクセルレイヤーをほかのオブジェクトと同じようにコピーします。コピーはどこかがペイントされるまでタイルを共有するため、負荷はわずかです。
オブジェクト > ピクセルレイヤー > 下のレイヤーと結合は、ピクセルレイヤーをすぐ下のピクセルレイヤーに統合して上のレイヤーを削除し、2 つを合成した 1 つのレイヤーを残します。たとえば一方が回転されているなど、レイヤーの変形が異なる場合は、結合時に上のレイヤーが下のレイヤーのグリッドに再サンプリングされます。
2 つのコマンドは面全体に一度に作用します。
- オブジェクト > ピクセルレイヤー > 塗りのカラーで塗りつぶす
- 面全体を現在の塗りのカラーで塗りつぶします。上からペイントする前に下塗りをしたり、ほかのアートの背後に置いたレイヤーを塗りつぶしたりするのに使います。
- オブジェクト > ピクセルレイヤー > 消去
- レイヤーを削除せずに面を空にするため、レイヤーの位置、変形、不透明度、描画モードを保ったまま、ペイントをやり直せます。
どちらのコマンドも効果 > ピクセルレイヤーにもあります。
レイヤーマスク
レイヤーマスクは、ピクセルレイヤーの一部を削除せずに隠します。マスクが白い場所ではレイヤーが見え、黒い場所では隠れ、その中間のグレーでは部分的に透明になります。何も消去されないため、マスクは何度でも塗り直せます。コマンドはオブジェクト > ピクセルレイヤーにあります。
- レイヤーマスクを追加
- 最初はすべてを表示するマスクを追加し、ペイントできる状態にします。
- 選択範囲からレイヤーマスクを追加
- 現在のピクセル選択範囲からマスクを作ります。内側は残り、外側は隠れます。写真から形を非破壊的に切り抜くすばやい方法です。
- マスクを編集
- マスクへのペイントをオンとオフで切り替えます。オンの間は、ブラシ、消しゴム、塗りつぶしツールがレイヤーではなくマスクにペイントします。黒(または暗いカラー)で塗ると隠れ、白で塗ると表示され、グレーで塗ると薄くなります。ブラシは現在の塗りのカラーの明るさを使うため、黒は隠し、白は表示します。
- レイヤーマスクを適用
- マスクをレイヤーに恒久的に焼き付け(隠れていたピクセルは透明になります)、マスクを削除します。
- レイヤーマスクを削除
- マスクを破棄し、レイヤー全体を手を加えないまま再び表示します。
マスクのあるレイヤーは、マスクが適用された状態で書き出しと保存が行われ、ほかのレイヤーと同じように描画モードの適用や変形ができます。
ベクターアートをピクセルに変換する:ラスタライズ
オブジェクト > ラスタライズは、現在の選択範囲をそれ自体の埋め込み画像に置き換え、パス、テキスト、効果を固定されたピクセルに焼き付けます。ベクターの結果を編集できない状態にしたいとき、効果を平らな画像として扱う方が簡単なとき、あるいはライブの構造を持たずにどこでも同じに見えるべき作品を渡すときに使います。結果はペイント可能なピクセルレイヤーではなく埋め込み画像なので、再び編集する可能性がある場合は元のアートワークのコピーを残しておいてください。表示 > ピクセルプレビュー(⌥⌘Y)を使うと、確定する前にベクターアートがピクセルグリッドにどう乗るかを確認できます。
保存と書き出し
.cut ドキュメントは、ピクセルレイヤーをほかのアートワークと一緒に保持します。平坦な領域はほとんど容量を取らないように圧縮され、ペイントしたとおりに正確に開き直せます。
ピクセルレイヤーがドキュメントからどのように出力されるかは形式によって異なります。
- PNG、JPEG、WebP
- ドキュメント全体をピクセルに統合するため、ペイントしたものと描画したものが 1 つのビットマップにまとまります。PNG は透明部分を保持できます。よりシャープな結果にするには @2x で書き出します。
- SVG と PDF
- ペイントした面を、ベクターアートの間に置かれた埋め込み画像として書き出すため、描画とペイントが混在するドキュメントも、シェイプをくっきり保ったまま 1 つのファイルとして持ち運べます。
ラスターとベクターが同じドキュメントに共存して一緒に書き出されるため、自然な方法で作品を作れます。すっきりしたシェイプとテキストはベクターで、やわらかな光彩、テクスチャーのあるウォッシュ、レタッチした写真など、絵の具の質感がほしい部分はその間に重ねたピクセルレイヤーで作ります。