Scissor

パスの描画と編集

Scissor のベクターオブジェクトはすべてパス、つまり直線または曲線のセグメントでつながれたアンカーポイントの連なりからできています。このページでは、パスの描き方、ポイント単位での形の変え方、そしてパスを連結、オフセット、アウトライン化、合成するコマンドを説明します。

ショートカットは macOS の表記で記載しています。Windows では、⌘ を Ctrl、⌥ を Alt、⇧ を Shift と読み替えてください。

アンカーポイント、ハンドル、パスの形

パスはアンカーポイントの連なりです。隣り合う 2 つのアンカーポイントの間にはセグメントがあり、どちらのアンカーポイントもセグメント側にハンドルを伸ばしていなければ直線、一方または両方が伸ばしていれば曲線になります。アンカーポイントの伸び方は 2 本の方向線ハンドルで決まります。入ってくる側のハンドルはアンカーポイントに到達するセグメントの形を、出ていく側のハンドルはアンカーポイントから出るセグメントの形を決めます。ハンドルを遠くへドラッグするほど、曲線はそちらへ強く膨らみます。パスには、2 つの端点が離れたオープンパスと、最後のアンカーポイントが最初のアンカーポイントにつながるクローズパスがあります。

コーナーポイントとスムーズポイント

アンカーポイントは、コーナーポイントかスムーズポイントのどちらかです。スムーズポイントでは 2 本のハンドルがアンカーポイントを通る一直線に固定されるため、曲線は折れ曲がらずに通り抜け、連続したままになります。コーナーポイントでは両側が独立しています。パスは鋭く向きを変えることができ、片側を直線、もう片側を曲線にすることもできます。ほとんどのシェイプは両方を組み合わせており、流れるような部分にはスムーズポイント、縁が曲がる場所にはコーナーポイントを使います。

スムーズポイント
ハンドルが一直線につながっています。葉の側面や文字の丸い部分など、1 つの連続したカーブに見せたい曲線に沿って使います。
コーナーポイント
ハンドルが別々に動くか、ハンドルがまったくないポイントです。星の先端、箱の角、曲線が直線の縁と出会う場所などに使います。

アンカーポイント、ハンドル、ダイレクト選択ツール

ダイレクト選択ツール(A)は、パスの各部分を操作します。アンカーポイントをクリックすると選択され、⇧ を押しながらクリックすると追加または解除されます。何もない場所で囲むようにドラッグすると、その中のアンカーポイントがすべて選択されます。選択したアンカーポイントをドラッグすると移動し、⇧ を押すと移動が 45° 単位に制限されます。シェイプがほぼ正しく、1、2 個のポイントを少し動かすだけでよいときにいつでも使えます。

ハンドルをドラッグすると、その側の曲線が変わります。スムーズポイントに属するハンドルは一緒に動くため、曲線は連続したままです。ドラッグ中に ⌥ を押すとそのつながりが切れて片側だけを操作でき、⇧ を押すとハンドルの角度が制限されます。セグメント自体をドラッグすることもできます。曲線のセグメントはポインターの下で曲がり、直線のセグメントは両端のアンカーポイントごと移動します。

グループ選択ツールはこの位置を共有しており、アンカーポイントではなく、グループの中からオブジェクト全体を選びます。1 回クリックすると最も内側のオブジェクトが選択され、もう一度クリックするとそれを囲むグループへと範囲が広がります。

描画ツール

Scissor には、パスをゼロから描くためのツールが 3 つあります。ペンはポイントごとに正確に制御でき、曲線ツールは配置したポイントを通るなめらかな曲線を当てはめ、鉛筆は手の動きに自由に従います。

ツールショートカット最適な用途
ペンPすべてのアンカーポイントとハンドルを意図して配置する、正確な輪郭。
曲線⇧~ハンドルを操作せずに、いくつかの通過点で決める流れるような曲線。
鉛筆Nラフな手描きのシェイプやすばやいスケッチ。

ペンツール

ペンツール(P)は、ポイントを 1 つずつ置いてパスを作ります。クリックするとコーナーのアンカーポイントが置かれます。代わりに押したままドラッグするとアンカーポイントにハンドルが付き、パスはそこから曲線として出ていきます。ドラッグ中に ⇧ を押すとハンドルが 45° 単位に制限され、⌥ を押すと出ていく側のハンドルだけが動き、アンカーポイントがコーナーになって次のセグメントが前のセグメントから独立します。

パスを描いている間は、ポインターを重ねた場所によってツールの動作が変わります。最初のアンカーポイントの上ではパスを閉じ、セグメントの上ではアンカーポイントを追加し、既存のアンカーポイントの上ではそれを削除します。描画中のパスがないときにオープンパスの端点の上にポインターを重ねると、そのパスを取り込み、そこから続けて描けます。Enter または Esc でパスを終了してオープンのまま残し、Delete で最後に置いたアンカーポイントを削除します。

曲線ツール

曲線ツール(⇧~)は、クリックしたポイントを通るなめらかな曲線を当てはめ、描いている間はポインターまでのプレビューが表示されます。⌥ を押しながらクリックするとスムーズポイントではなくコーナーポイントが置かれ、どのポイントもダブルクリックすると 2 種類の間で切り替わります。ポイントをドラッグして動かすと、曲線が当てはめ直されます。最初のポイントをクリックするとシェイプが閉じ、Enter を押すと終了します。Delete は最後のポイントを削除し、Esc はパスを破棄します。ハンドルを自動で計算してくれるため、正確なアンカーポイントより曲線の形を重視するときに使います。

鉛筆ツール

鉛筆ツール(N)はフリーハンドで描きます。押して、描いて、離すと、Scissor がその軌跡を通るなめらかなパスを当てはめます。描き始めた場所の近くで離すか、終えるときに ⌥ を押すと、パスが閉じてシェイプになります。結果は現在の線のカラーで線が付いたオープンパスなので、線としてそのまま残すことも、塗りつぶすこともできます。当てはめたパスがどれだけ手の動きに忠実かは、鉛筆の精度の環境設定で決まります。「精細」ではアンカーポイントを多く残してぶれもすべて保ち、「滑らか」ではアンカーポイントを減らして線をならします。スケッチ、署名など、組み立てたものではなく手描きに見せたいシェイプに使います。

パス上のポイントの編集

ポイントの追加、削除、切り換え

ペンは、アンカーポイントの追加(+)、アンカーポイントの削除(−)、アンカーポイントツール(⇧C)とツールバーの位置を共有しています。アンカーポイントの追加は、曲線を変えずにセグメント上に新しいポイントを置きます。アンカーポイントの削除は、クリックしたポイントを削除し、パスがそのすき間をつなぎます。アンカーポイントツールでは、コーナーのアンカーポイントからドラッグすると対になったハンドルが引き出されてスムーズポイントになります。片方のハンドルをドラッグすると対が切れて両側が別々に動き、コーナーポイントに戻ります。スムーズポイントをクリックすると、ハンドルが取り除かれて鋭いコーナーになります。

オブジェクト › パスには、選択範囲全体に一度に作用するコマンドとして同じ編集があります。アンカーポイントの追加は、すべてのセグメントの中央に新しいアンカーポイントを置き、形を変えずにポイント数を 2 倍にします。きれいに曲げるためにより多くのポイントが必要なゆがみやワープの前に便利です。アンカーポイントの削除は、ダイレクト選択ツールで選択したアンカーポイントを取り除き、残ったポイントでパスを当てはめ直します。

手作業での形の変更:スムーズツール、パス消しゴムツール、連結ツール

ブラシのように使う 3 つのツールは、1 つのアンカーポイントではなく、ドラッグした場所でパスの形を変えます。選択したパスに作用し、何も選択していない場合はブラシの下にあるパスに作用します。[ と ] でブラシを小さく・大きくします。

スムーズツール
パスに沿ってドラッグすると、アンカーポイントを間引いて凹凸をやわらげ、パスをなだらかにします。ぶれた鉛筆の線やトレースした縁を落ち着かせるのに使います。
パス消しゴムツール
パスに沿ってドラッグすると、横切った部分を消し、パスを分割したり短くしたりします。線から余分な端を切り取るのに使います。
連結ツール
2 つのオープンな端点をこするようにドラッグすると連結され、パスが延長または切り詰められて角できれいに出会います。2 本の線が出会うはずだったすき間を閉じるのに使います。

パスの切断:はさみとナイフ

はさみツール(C)は 1 か所で切断します。セグメントまたはアンカーポイントをクリックすると、そこでパスが分割されます。クローズパスは切断位置で開き、オープンパスは 2 つの別々のオブジェクトに分かれます。円に切れ目を入れたり、シェイプを分けて半分ずつ異なるスタイルにしたりするのに使います。

ナイフはアートワークをまっすぐ横断して切り分けます。オブジェクトの上で刃をドラッグすると、描いた線に沿って別々のピースに切断されます。⌥ を押すと直線で切断し、さらに ⇧ を加えるとその線が 45° 単位に制限されます。何かが選択されている場合は選択したオブジェクトだけが切断され、それ以外の場合は刃が横切るものすべてが切断されます。塗りのあるシェイプを 1 回のストロークで複数のクローズドなピースに切り分けるのに使います。

パスのコマンド

オブジェクト › パスには、パス全体に一度に作用する操作がまとめられています。

コマンドショートカット機能
連結⌘Jオープンな端点をつないで 1 つのパスにするか、1 つのオープンパスを閉じます。
平均…⌥⌘J選択したアンカーポイントを共通の位置に移動します。
パスのアウトライン線を、同じ輪郭を持つ塗りのシェイプに変換します。
パスのオフセット…指定した距離だけ広げた、または縮めたコピーを作ります。
パスの方向反転パスの進む向きを反転します。
単純化…アンカーポイントの数を減らします。
アンカーポイントの追加すべてのセグメントの中央にポイントを追加します。
アンカーポイントの削除選択したアンカーポイントを削除します。
グリッドに分割…選択範囲を行と列のグリッドに切り分けます。
パスの削除…孤立点、塗りも線もないオブジェクト、空のテキストを削除します。

連結と平均

連結(⌘J)はオープンパスに作用します。2 つの別々のオープンパスを選択している場合は、最も近い端点同士をつないで 1 つのパスにします。1 つのオープンパスの場合は、2 つの端点をつないで閉じます。すでに重なっている端点は 1 つのアンカーポイントに統合されます。オープンな輪郭として描いたシェイプを閉じたり、途中まで描いた 2 本の線をつなぎ合わせたりするのに使います。

平均(⌥⌘J)は、選択したアンカーポイントを共通の平均位置に移動します。ダイアログでは、ポイントを同じ高さに揃える水平方向、縦一列に揃える垂直方向、すべてを 1 点に重ねる両方向を選べます。並んだポイントの高さを揃えたり、連結する前に 2 つの端点を近づけたりするのに使います。

単純化

単純化は、設定した精度の範囲内で、選択したパスをより少ないアンカーポイントで描き直します。精度を高くするとポイントが増える代わりに元に近い形を保ち、低くするとシェイプをわずかなポイントになめらかにまとめます。シェイプに必要な数よりはるかに多くのポイントを持つ、トレースしたパスや手描きのパスを整理するのに使います。編集も描画も軽くなります。

パスのオフセット

パスのオフセットは、元のパスから指定した距離に新しいパスを作ります。正のオフセットは輪郭を外側に広げて元のパスの背面に置き、負のオフセットは内側に縮めて前面に置きます。角の形状の設定で外側の角の処理方法を決めます。鋭い「マイター」、丸い「ラウンド」、平らにした「ベベル」があり、比率で鋭い角が切り落とされるまでの長さの上限を決めます。シェイプの周りに均一な縁取りを描いたり、キーライン用にシェイプを内側に縮めたり、細い形を太らせたりするのに使います。パスのオフセットは、効果 › パスにも、シェイプが変わると再計算されるライブ効果として用意されています。

パスのアウトライン

パスのアウトラインは、線の付いたパスを、線の輪郭とまったく同じ形の塗りのシェイプに置き換えます。アウトライン化すると、幅はオブジェクトと一緒に拡大・縮小されなくなり、線として編集することもできなくなりますが、輪郭をポイント単位で変形したり、グラデーションで塗ったり、ほかのシェイプと合成したりできます。線をアートワークとして扱いたいとき、たとえば線に先細りや変化のある縁を付けて手作業で調整したいときや、デザインを拡大・縮小しても線の太さを固定しておきたいときに使います。これも効果 › パスにライブ効果として用意されています。

パスの方向反転

パスの方向反転は、アンカーポイントの並び順を反転し、パスが逆向きに進むようにします。方向はそれだけで見えることはめったにありませんが、複合パスでどの輪郭が穴になるか、ブラシや矢印がどこで始まりどこで終わるかを決めます。複合パスの穴が塗りつぶされてしまったときや、パス上文字や線の始点と終点が逆側にあるときに使います。

編集可能なシェイプとそのウィジェット

長方形、角丸長方形、楕円形、多角形はライブのまま保たれます。パラメーターを保持し、いずれかを変更するたびにパスを作り直します。シェイプをドラッグして描いている間、⇧ を押すと正方形や正円などの均等な形になり、⌥ を押すと中心から描きます。ドラッグ中には矢印キーも使えます。上と右で増やし、下と左で減らして、多角形の辺の数、星の頂点の数、角丸長方形の角の半径を変更します。

ライブシェイプを 1 つ選択すると、角のすぐ内側に小さな丸いハンドルが表示されます。シェイプが画面上で小さすぎてはっきり表示できない場合は隠れます。選択ツール(V)でハンドルをドラッグするとすべての角が一度に丸くなり、ダイレクト選択ツールでドラッグすると、つかんでいる角だけが丸くなります。⌥ を押しながら角のハンドルをクリックすると、角丸(外側)、角丸(内側)、面取りの順に切り替わります。この場合も、選択ツールでは 4 つの角すべて、ダイレクト選択ツールでは 1 つの角が対象です。

楕円形には代わりに四角いハンドルが表示されます。完全な楕円には 1 つ、扇形を開いた後はその両端に 1 つずつです。ハンドルをドラッグするとシェイプからくさび形が開き、⇧ を押すと角度が 15° 単位にスナップします。終点を始点まで戻すと完全な楕円に戻ります。プロパティパネルには同じ値が数値で表示されます。半径と角の種類、角ごとの半径、多角形の辺の数、扇形の開始角度と終了角度(度)です。ライブシェイプは、パスを直接編集して通常のパスになるまで、これらの設定を保持します。

シェイプの合成:結合・分割とシェイプの合成

2 つ以上のシェイプが重なっているとき、そこから 1 つの新しいシェイプ、たとえば合体した形、穴、交差する部分などを作りたいことがよくあります。Scissor には 2 つの方法があります。結合・分割は直接的で視覚的な方法で、シェイプの合成パネルは同じ操作をボタンで適用します。どちらも曲線を線分に平坦化せずに保ちます。

結合・分割ツール

結合・分割ツール(⇧M)は、選択した 2 つ以上のパスに作用します。重なりを領域に分割し、ポインターが重なっている領域をハイライト表示します。複数の領域を横切るように線をドラッグすると、それらが 1 つのオブジェクトに結合され、元のシェイプのアピアランスを引き継ぎます。⌥ を押しながらドラッグすると、それらが削除されます。ステップごとにコマンドを選ぶ手を止めずに、必要な部分を加え、不要な部分を消して、目で見ながらシェイプを組み立てるのに使います。

シェイプの合成の形状モード

シェイプの合成パネル(⇧⌘F9)の上部には 4 つの形状モードがあり、いずれも選択したパスを 1 つの合成パスに置き換えます。結果は最前面のオブジェクトのアピアランスを引き継ぎます。ただし、前面オブジェクトで型抜きは最背面のオブジェクトのアピアランスを保ちます。

合体
選択したすべてのシェイプを 1 つの輪郭に統合します。並んだ円から雲を作るように、重なり合う部品を溶接して 1 つのシルエットにするのに使います。
前面オブジェクトで型抜き
最背面のシェイプを残し、その前面に重なるものをすべて切り取ります。2 つの円から三日月を彫り出すように、シェイプの一部をかじり取るのに使います。
交差
選択したすべてのシェイプが共有する領域だけを残します。2 つの円が交わるレンズ形のように、アートワークを共通の領域まで切り詰めるのに使います。
中マド
重なりを除いたすべてを残し、重なりは穴になります。交差する部分が抜け落ちるリングや鎖の輪を作るのに使います。
円、角丸の正方形、円の 3 つの重なり合うシェイプが、1 つの合成されたシルエットに統合される様子。
合体(または結合・分割でのドラッグ)は、重なり合うシェイプを、曲線を保ったまま 1 つの輪郭に統合します。

シェイプの合成のその他の操作

形状モードの下には 6 つのパスファインダーがあります。これらは 1 つの合成パスではなく、グループにまとめた複数のピースを残します。背面オブジェクトで型抜きは、同名の形状モードと対応する操作ですが、最前面のシェイプを残します。

分割
シェイプを交差するすべての線で別々の面に切り分け、各面はそれを覆う最前面のシェイプのカラーになります。ステンドグラスの区画のように、デザインを塗り分けられるピースに分けるのに使います。
刈り込み
各シェイプのうち、上にあるシェイプに覆われて隠れている部分を取り除きます。各ピースは独自の塗りを保ち、統合はされません。線は削除されます。重ねた単色のアートワークを平坦化し、色が別の色の上に印刷されないようにするのに使います。
合流
隠れている部分を刈り込んでから、塗りのカラーが同じ隣り合うピースを合体します。単色のイラストを整理し、同じ色の領域を 1 つのシェイプにまとめるのに使います。
切り抜き
下にあるシェイプのうち、最前面のシェイプの内側に入る部分だけを残し、最前面のシェイプは破棄します。ライブのクリッピングマスクを保つのではなく、アートワークを枠でクリップして切り抜きをパスに焼き付けるのに使います。
背面オブジェクトで型抜き
最前面のシェイプを残し、その背面にあるものをすべて切り取ります。最前面のシェイプを残し、その下のシェイプで彫り込みたいときに使います。
アウトライン
すべての領域の境界を、元の塗りのカラーで線を付けたオープンな線に変換します。重なり合うシェイプのセットから、縁の骨組みを取り出すのに使います。

効果 › シェイプの合成は、代わりに追加、交差、中マド、型抜き、背面オブジェクトで型抜きをグループへのライブ効果として適用し、元のオブジェクトは下で無傷のまま編集可能に保ちます。後で部品を動かす可能性があるときは効果の方を、合成したシェイプが最終形のときはパネルを使います。

複合パスとクリッピングマスク

オブジェクト › 複合パス › 作成(⌘8)は、選択したパスを奇偶ルールで塗る 1 つのオブジェクトにまとめるため、内側の輪郭がそれを囲む輪郭に穴を開けます。結果は選択範囲の最背面のオブジェクトのアピアランスを引き継ぎます。解除(⌥⇧⌘8)は、各輪郭を独立したパスに戻します。文字 O のカウンターやワッシャーなど、穴のあるシェイプには複合パスを使います。

オブジェクト › クリッピングマスク › 作成(⌘7)は、選択した最前面のオブジェクト(パスである必要があります)を使って、その下にあるものをすべてクリップします。Scissor はそれらをすべてクリップグループに入れ、マスクパス自体の塗りと線を消去します。解除(⌥⌘7)はクリップグループを通常のグループに戻すため、何もクリップされなくなり、マスクパスを含むすべてのオブジェクトは元の位置に残ります。同じサブメニューの不透明マスクを作成は、輪郭ではなく濃淡でマスクするため、マスクの明るい部分は透けて見え、暗い部分は隠れます。

スマートガイドとスナップ

スマートガイド(表示 › スマートガイド、⌘U)は、描画中やドラッグ中に、表示されているアートワークとボードを監視します。動かしているものは近くのオブジェクトの端、中心、アンカーポイントにスナップし、揃った相手まで線が表示され、一致の種類(アンカー、中心、コーナー、整列)がラベルで示されます。

さらに 2 種類のガイドが自動的に表示されます。動かしているオブジェクトが、隣のオブジェクト同士の間隔と同じ距離に来ると、そこにスナップし、2 つの等しい間隔が寸法付きで描かれます。これは等間隔に並んだオブジェクトの列を続ける場合にも、2 つの間のすき間に 1 つを中央配置する場合にも機能します。また、始点から離れるようにドラッグすると、方向が角度の制限から 45° ごとの補助線にスナップし、横に角度が付いた長い線として描かれます。

ポイントにスナップ(⌥⌘')とグリッドにスナップ(⇧⌘')は、表示メニューにある別々のスイッチです。グリッドにスナップがオンのときは、すべてがグリッドの分割線上に配置され、スマートガイドは働きません。